QGIS Python Plugins Repository

Version: [1866] SPARQLing Unicorn QGIS Plugin 0.15 Experimental

Changelog
0.15: HTML documentation generation, BBOX Dialog and Enrichment Dialog improved,
usage of more QGIS UI elements, related concept view, query layer data in bbox,
improvements to triple store detection<br>0.14.1: Improved Compatibility for
SPARQL 1.0 Endpoints, Automated Configuration Updates, Fixes for
GeoShapes<br>0.14: New icon set, UI design using layouts, improved item views,
reworked triple store configuration, support for wgs84:geometry, graph
validation with pyshacl, convert layer to neogeo RDF, began multilanguage
literal support, mark linked geo concepts<br>0.13.1: fixed icons and RDF
export<br>0.13: Added classtree for navigation, support for SPARQL endpoints
with HTTP Auth, support for GeoSPARQL 1.1 FeatureCollections, Added context menu
for classtree, Added support for schema.org encoded geometries, smaller
bugfixes<br>0.12.2: Support for Wikidata Geoshapes, fallback for non-standard
conform literal definitions<br>0.12.1 Fix for lat/lon based triple stores,
polygon BBOX<br>0.12 Plugin is now based on QgisTasks, BBOX dialog improved,
quick add new triple stores, SPARQL interface improvements, improved list view
of geo-classes, ability to add converted RDF sets to triple stores<br>0.11:
Added interlinking and enrichment dialog (experimental), use dataset columns as
query vars, search for concepts to include in your SPARQL query<br>0.10: Bundled
dependent libraries, added new triple stores, added support for non-geo
queries<br>0.9: Add triplestore functionallity, add more endpoints<br>0.8:
Syntax Highlighting and query validation, support for bbox queries, import and
export of rdf files, Preloading of geoconcepts from triple stores<br>0.7: add
support for DBpedia and GeoNames<br>0.6: add support for
linkedgeodata.org<br>0.5: add support for kerameikos.org<br>0.4: add support for
nomisma.org<br>0.3: add support for more multiple vars and add Ordnance Survey
UK SPARQL endpoint<br>0.2: bugfixes and more user comfort<br>0.1: initial commit
Approved
yes
Author
fthierygeo
Uploaded
Nov. 8, 2022, 8:25 a.m.
Minimum QGIS version
3.0.0
Maximum QGIS version
3.99.0
External dependencies (PIP install string)
None
Experimental
yes

Version management

Plugin details

Sustaining Members