Related Plugins and Tags

QGIS Python Plugins Repository

Version: [2074] Google Earth Engine Data Catalog 0.4.2

Changelog
[0.4.2] - 2021-09-12
- Planet & NICFI Basemaps for Tropical Forest Monitoring datasets.
- Hansen Global Forest Change v1.8 (2000-2020) dataset.
[0.4.1] - 2020-10-13
- No longer restart the output directory, closing issue #3.
- Single band dataset min/max conf.
- Signal disconnect on plugin unload.
[0.4.0] - 2020-10-01
- Save the xml files in an output directory or in the temporary folder.
- Fixed the rewriting of xml files in project load.
- Option in context menu to renew XML file.
- Updated to Mapbiomas collection 5.0
[0.3.0] - 2020-08-10
- Changed icon.
- Save xml and update layers on project read.
- Initialized ee library only once and after plugin loading.
[0.2.1] - 2020-06-29
- UI bug fixed, closing issue #1.
- Removed some plugin-builder stuff.
- Using compiled Python code rather than load the user interface description
file.
[0.2.0] - 2020-06-23
- Band combination Shortwave infrared 3 (B12-B8A-B2) in Sentinel2 datasets.
- Scene Classification Map band for Sentinel 2 SR dataset.
- Global extent datasets: ALOS DEM, PALSAR FNF and Global Forest Canopy Height.
- ASTER radiance and ALOS/AVNIR-2 datasets.
- MapBiomas datasets (Annual Land Use Land Cover Maps of Brazil).
- Loading qml for singleband/palleted pseudo color datasets.
- TOA and raw datasets for Landsat 8 and 5.
- HSV Pan-sharpened images for TOA Landsat 8 and 5 datasets.
- Landsat 7 and 4 datasets (SR, TOA and raw).
- MSS for Landsat 4 and 5.
- Contrast enhancement to full ee.image layer before loaded.
- Set layer abstract with info about image date.
[0.1.0] - 2020-05-31
- Search images collections by canvas extent, date and cloud cover.
- Add image layers as WMS/TMS by GDAL XML in memory.
- Add custom properties to layers to save with project file
- Download to Google Drive in context menu (full image and clip to canvas
extent).
- Sentinel-2 collections (SR and TOA) and Landsat 8 and 5 Tier 1 and 2
Approved
yes
Author
sandroklippel
Uploaded
Sept. 13, 2021, 1:27 p.m.
Minimum QGIS version
3.10.0
Maximum QGIS version
3.99.0
External dependencies (PIP install string)
None
Experimental
no

Version management

Plugin details

Sustaining Members