QGIS Python Plugins Repository

Version: [579] QuickOSM 2.1.1

Changelog
Version 2.1.1:
* Add a warning if the key has a trailing white space (contribution from
@kannes)
* Improve the UI by moving buttons up and adding icons to them
* Fix some Python exceptions which weren't displayed to the user
* Switch to POST HTTP request instead of GET for QGIS ≥ 3.22
* Fix an issue when installing QuickOSM plugin

Version 2.1.0:
* Check that QGIS Processing algorithm is available before opening the QuickOSM
dialog
* Improve help how to create map preset on the online help
* Improve the help about add some QML in queries
* Fix Python exception if the user input is not recognised as a valid preset
* Update default JOSM/Vespucci presets from 2.9.0 to 4.8.0

Version 2.0.1:
* Fix trunk roads to Urban visualization preset (contribution from @Rikuoja)
* Fix an error when running Python 3.10
Approved
yes
Author
Gustry
Uploaded
Aug. 21, 2022, 4:09 a.m.
Minimum QGIS version
3.16.0
Maximum QGIS version
3.99.0
External dependencies (PIP install string)
None
Experimental
no

Version management

Plugin details

Sustaining Members