QGIS Python Plugins Repository

Version: [579] QuickOSM 1.17.1

Changelog
Version 1.17.1:
* Add a reminder of the copyrights
* Fix loading of translations files
* Fix an error triggered when there was no layer in the project that prevented
the generation functionality
* Fix an error when using QuickOSM in a Processing model

Version 1.17.0:
* Add OpenHistoricalMap overpass server, linked to
https://www.openhistoricalmap.org
* Add an option to use the extent of selected features
* Add Overpass Query Language (OQL) generator by default instead of legacy XML
* Add the possibility to choose the Nominatim server, by default the one from
qgis.org
* Add one check from the Overpass API if too many requests from the user
* Fix the Mapillary action in the attribute table
* Fix some user experience issue about the place name
* Fix user experience about the named area drop-down menu
* Fix 'Around' query type to fetch any OSM object instead of only OSM nodes.
* In the source code, add some Python annotations and more tests

Version 1.16.0:
* Changelog from 1.15.0 which has been unapproved
* Avoid regression from 1.15.0 about empty attribute table
* Always check to open file with UTF8
Approved
yes
Author
Gustry
Uploaded
June 24, 2021, 5:18 a.m.
Minimum QGIS version
3.4.0
Maximum QGIS version
3.99.0
External dependencies (PIP install string)
None
Experimental
no

Version management

Plugin details

Sustaining Members