Related Plugins and Tags

QGIS Python Plugins Repository

Version: [683] OS Translator II 1.4.1

Changelog
1.4.1 - New features and bug fixes:
- Support for schema 9 (issue #25)
- Support for downloads behing proxy (issue #16)
<p>1.3.0 - New features:
- Being able to run the tool from the command-line
<p>1.2.4 - Bug fixes:
- Ensured previous fixes don't break in GDAL 1.x
<p>1.2.3 - Bug fixes:
- Fixed "no COPY in progress" error seen in QGIS 2.14.0
- Fixed traceback seen when schema left blank
- Tidied line endings in reporting
- Provided better error reporting the event of being unable to save styles to
the db
<p>1.2.2 - Bug fixes:
- Cleaned-up error messages
- Added hints about setting up prerequisites for OS styles
- Much improved error checking and reporting on downloading of styles
- Ensured failing stylesheet download does not kill post-processor thread
- Improved logic around style-related controls
- Fixes bug where styles only applied when data already existed in database
<p>1.2.1 - New features:
- Updated metadata.txt to new requirements
<p>1.2 - New features:
- Automatic addition of new fields required for Ordnance Survey QGIS styles
- Automatic download and application of Ordnance Survey MasterMap stylesheets
- Bug Fixed:
- Improved Linux support
- Improved support for implied / default db fields
- Various other improvements
<p>1.1 - New features:
- Added UI elements to allow user control over spatial indexing and
de-duplication
- Bug fixes:
- Fixed issue #2 import continues even after errors with input fields are
detected
- Fixed issue #7 road names not being imported
- Fixed issue #5 geometry-less features seen at 0,0 and some tables not being
indexed or de-duplicated
<p>1.0 - New features:
- Added timing
- Added status bar and responsive and verbose indexing
- Added de-duplication step for chunked data
- Bug fixes:
- Added workarounds for ogr2ogr issues
- Added Pioneer file for ITN and topo
- Made indexer more granular for progress reporting
<p>0.2 - Bug fixes:
- Fix for "IOError: [Errno 2] No such file or directory: '/tmp..."
- Fix for "IOError: [Errno 9] Bad file descriptor"
- With thanks to the reporters
<p>0.1 - Initial release
Approved
yes
Author
sabb
Uploaded
April 4, 2017, 9:12 a.m.
Minimum QGIS version
2.0.0
Maximum QGIS version
2.99.0
External dependencies (PIP install string)
None
Experimental
no

Version management

Plugin details

Sustaining Members