QGIS Python Plugins Repository

Version: [1330] trends.earth 0.56

Changelog
0.44
- Add JRC LPD
- Add tool for uploading custom land cover data
- Add tool for uploading custom productivity data
- Add note that custom SOC upload is coming soon
- Add tool to add basemaps using Natural Earth data
- Add all-in-one tool for calculating all three sub-indicators at once
- Rename "Bare lands" class to "Other lands" for consistency with UNCCD
- Update docs
- Upgrade to marshmallow 3.0.0b7
- Move GEE code into the main trends.earth repository
- Improve handling of AOIs, particularly when shapefiles are used for input
- Handle multi-file outputs from GEE by tiling them in VRTs
- Support processing data for countries that cross the 180th meridian
- Improve formatting of summary table
- From now on, GEE script versions will be matched to the plugin version
0.42
- Fix crash on change of LC aggregation (due setEnabled on removed label)
0.40
- Remove use of mode for land cover indicator.
- Combine the summary table and SDG indicator map creation tools.
- Add stub for where JRC LPD product will be available.
- Save productivity sub-indicator as band 2 in SDG indicator file.
- Bump GEE script to v0.3.
- Fix error due to divide by zero on summary table generation when a class
has zero area.
- Default to MODIS for productivity calculations.
0.38
- Add annual soil organic carbon calculation
- Add annual soil organic carbon calculation
- Cleanup AOI processing code, allow multiple input polygons in shapefile
AOIs
- Add shading to side of land cover aggregation table items
- Fix firstShow issue on aggregation table
- Revise summary table output to provide further information on each of the
three indicators
- Add supplemental datasets to performance, state, land cover and soil
organic carbon output.
- Update no data and masking values to consistently be -32768 (no data) and
-32767 (masked data)
- Allow naming of file downloads
- Add icon to toolbar menu, fix plugin name.
- Refactor layer styling code to pull band info from GEE output.
- Add a tool to load existing trends.earth datasets into QGIS.
- Fix land cover date limits - don't allow invalid dates toi be selected
from CCI data.
0.36
- Fix issue with showEvent on create map reporting tool.
Approved
yes
Author
azvoleff
Uploaded
April 9, 2018, 10:39 p.m.
Minimum QGIS version
2.18.0
Maximum QGIS version
2.99.0
External dependencies (PIP install string)
None
Experimental
no

Version management

Plugin details

Sustaining Members