QGIS Python Plugins Repository

Version: [1247] Data Plotly 3.3

Changelog
Version 3.3
- [bugfix] better loading project part 2
Version 3.2
- [bugfix] fix violin plot bug
- [bugfix] better loading project handling
Version 3.1
- [feature] more data defined options available (in layout customization).
Thanks @SGroe
- [feature] X and Y axis bounds limits. Thanks @SGroe
- [feature] add box plot within violin plots
- [feature] renaming of plugin metadata to better search. Thanks @Gustry
- [bugfix] Box plot not working when no group is selected
- [bugfix] Data-defined property overrides do not work in layout
Version 3.0
- [feature] total refactoring of the code
- [feature] plots also in print composer
- [feature] atlas based plots
- [feature] chance to save/load configuration file of plot setting
- [feature] plot settings saved together with the project
- [feature] more datadefined properties
- [feature] show only selected/visible/filtered features
- [feature] unit tests and continuous integration
Version 2.3
- [feature] tweaks polar plots, thanks @josephholler
Version 2.2
- [feature] UI tweaks, thanks @nyalldawson
Version 2.1
- [fix] typos in UI (thanks @leonmvd and @nyalldawson)
- [fix] better python packages imports (thanks @nyalldawson)
Version 2.0
- [feature] DataPlotly is updated with plotly 3.3 version
Version 1.6
- [feature] wheel zoom! Give it a try
- [feature] Edit plot title and X/Y labels in place
Version 1.5.1
- [feature] Spanish translation. Special thanks to Luca Bellani
- [bugfix] always open English manual if locale not translated
Version 1.5
- [feature] **new** Violin plots!
- [feature] **new** Polar plot layout!
- [feature] better default color choice
Version 1.4.3
- [bugfix] correct interaction with pie plot
- update plotly.js to v 1.34.0
Version 1.4.2
- [bugfix] correct saving html plot
Version 1.4.1
- [bugfixing] adaptation for new API
Version 1.4
- [feature] update plotly.js to v 1.33.1
- [feature] multiple selection with Shift + selection tool
- [feature] DataPlotly as Processing provider, thanks to Michaël Douchin of 3Liz
Approved
yes
Author
ghtmtt
Uploaded
Feb. 10, 2020, 4:23 a.m.
Minimum QGIS version
3.4.0
Maximum QGIS version
3.98.0
External dependencies (PIP install string)
None
Experimental
no

Version management

Plugin details

Sustaining Members